DDoS Attack Causing Degradation in EU
Resolved
Mar 31 at 12:46pm EET
✅ Status Update – Issue Resolved
Incident: Edge Infrastructure Degradation (EU - Frankfurt)
Status: Resolved
Downtime: None
The DDoS attack affecting our Edge Infrastructure in the EU, specifically in Frankfurt, has been successfully mitigated.
Our teams have restored normal performance across all impacted regions.
We’ll continue to monitor the situation closely to ensure stability.
Thank you for your patience and continued trust.
— Skytells Infrastructure Team
Affected services
Created
Mar 31 at 12:43pm EET
Degraded Performance on Edge Infrastructure (EU - Frankfurt)
We're currently experiencing degraded performance across parts of our Edge Infrastructure in the EU region, specifically impacting nodes in Frankfurt due to a massive DDoS attack targeting our global network.
Our engineering and security teams are actively mitigating the attack and working tirelessly to restore full functionality as quickly as possible.
We appreciate your patience and will provide continuous updates as we make progress.
Affected services