Back to overview
Degraded

Partial Degradation

Mar 05 at 12:01am EET
Affected services
Edge Infrastructure

Resolved
Mar 05 at 01:09am EET

Solved: Services are operating normally.

Earlier today, we observed partial degradation impacting a limited subset of services for users in Gulf regions. The issue was traced to disruption affecting one of our regional edge and connectivity partners, consistent with broader conditions impacting Gulf-area connectivity and infrastructure.

As mitigation, we executed our multi-partner failover strategy by isolating the affected path and temporarily rerouting Gulf-region edge traffic and dependent workloads to alternate partners and an optimal region. Service stability was restored, and latency and error rates returned to normal levels.

We will keep failover capacity in force and continue enhanced monitoring across Gulf entry points. Once the primary operator confirms a sustained return to normal conditions, we will progressively reroute traffic back under controlled validation to ensure continued reliability.

Updated
Mar 05 at 12:36am EET

As a mitigation, Gulf-region edge workloads and service delivery have been temporarily rerouted to an optimal region while we continue investigation.

Updated
Mar 05 at 12:17am EET

Current indicators suggest this is related to the ongoing situation impacting Gulf-region connectivity and infrastructure. We’ve informed our regional on-call engineering teams and are coordinating closely with our edge providers and data center partners to investigate and mitigate.

Updated
Mar 05 at 12:08am EET

We’re aware of the issue and are actively investigating with our edge providers and regional data center partners in Gulf region.

Created
Mar 05 at 12:01am EET

We are observing partial degradation in our Gulf edge layer, impacting a limited subset of services for users in the region. Effects may include intermittent latency increases and elevated error rates for a subset of API traffic.