Service Degradation Affecting Global Edge Infrastructure
Resolved
Jul 26, 2026 at 6:03pm UTC
Solved: Services are operating normally.
Earlier today, we observed service degradation affecting a subset of enterprise workloads following an external geopolitical event impacting one of our Global Edge Infrastructure facilities in the Gulf region.
As mitigation, we activated our regional resilience strategy by isolating the affected environment, enabling enhanced security safeguards and integrity verification procedures, and progressively rerouting eligible Gulf-region edge traffic and dependent workloads to unaffected Global Edge Infrastructure capacity across public and private high-availability resources. Mission-critical workloads remained online throughout the event, and service stability was restored while maintaining operational resilience.
No data loss or data integrity impact has been identified. High-availability resilience mechanisms maintained workload continuity throughout the incident response process, with customer workloads and platform state remaining consistent and no unauthorized or unintended changes detected. Infrastructure integrity validation activities were completed in coordination with our data center partners, confirming the environment remained within required operational and security controls.
We will keep failover capacity in force and continue enhanced monitoring across Gulf entry points. Once the primary operators and internal observability and validation systems confirm a sustained return to normal conditions, we will progressively reroute traffic back under controlled validation to ensure continued reliability and service resilience.
Affected services
Updated
Jul 26, 2026 at 5:53pm UTC
As a further mitigation, regional traffic engineering has been activated to transition eligible Gulf-region edge workloads to unaffected Global Edge Infrastructure capacity, maintaining service continuity while recovery operations progress.
Affected services
Updated
Jul 26, 2026 at 5:46pm UTC
Mission-critical workloads remain online and active, while affected compute capacity is progressively absorbed by private high-availability infrastructure to maintain uninterrupted processing and operational resilience.
Affected services
Updated
Jul 26, 2026 at 5:31pm UTC
The affected environment has been logically isolated to contain operational risk while eligible workloads are progressively transitioned to unaffected Global Edge Infrastructure capacity. Enhanced security safeguards and continuous integrity verification remain active throughout the recovery process.
Affected services
Updated
Jul 26, 2026 at 5:26pm UTC
As part of our mitigation efforts, additional security safeguards and integrity verification procedures have been activated across the affected environment. These measures reinforce platform resilience while recovery operations continue under heightened operational oversight.
Affected services
Updated
Jul 26, 2026 at 5:15pm UTC
Our investigation has identified the affected infrastructure. Regional on-call teams remain fully engaged alongside our edge infrastructure providers and data center partners as mitigation activities continue.
Further updates will be provided as restoration progresses.
Affected services
Created
Jul 26, 2026 at 5:08pm UTC
Our monitoring systems have identified a service degradation affecting a subset of enterprise workloads. The degradation is associated with an external geopolitical event impacting one of our Global Edge Infrastructure facilities in the Gulf region.
Our engineering teams and regional on-call responders have been mobilized and are actively coordinating response and recovery efforts.
Further updates will be provided as our investigation progresses.
Affected services